AZ stepper start command to motion delay

Discuss Stepper motors, Drivers, Controllers, GUI's and related Accessories here.
Post Reply
om_tech_support_MD
Posts: 13
Joined: Wed Dec 05, 2018 1:49 pm

AZ stepper start command to motion delay

Post by om_tech_support_MD » Mon Feb 24, 2020 2:21 pm

Question: I need a delay of 1ms or less between my start command to motor movement with the AZ series stepper. What is the fastest communication you offer?

communication delay chart.JPG
communication delay chart.JPG (23.3 KiB) Viewed 2463 times



The fastest option is a pulse and direction signal. With the pulse input driver there is a 0.1ms delay from the pulse and direction signal to motor movement. The only delay is just a hardware delay as there are no network conversions.
https://www.orientalmotor.com/products/ ... f#page=503
Pulse input communication delay.png
Pulse input communication delay.png (64.16 KiB) Viewed 2466 times

When using EtherCAT network communication you can set the communication period to 0.25s
EtherCAT communication delay.png
EtherCAT communication delay.png (111.43 KiB) Viewed 2466 times

When using EtherNET/IP network communication you can set the communication cycle to 1ms.
https://www.orientalmotor.com/products/ ... df#page=89
EtherNET_IP communication delay.png
EtherNET_IP communication delay.png (86.97 KiB) Viewed 2466 times

For our RS485 Modbus RTU driver there is a 4.5ms or more delay from the message to motor operation.
https://www.orientalmotor.com/products/ ... f#page=263
RS485 ModBUS RTU communication delay.png
RS485 ModBUS RTU communication delay.png (159.17 KiB) Viewed 2466 times
https://www.orientalmotor.com/products/ ... f#page=314
RS485 ModBUS RTU communication delay 2.png
RS485 ModBUS RTU communication delay 2.png (81.41 KiB) Viewed 2466 times

If you used a stored program in the driver with Modbus RTU there is a 6.5ms or less delay between the command and motor motion
https://www.orientalmotor.com/products/ ... f#page=309
Discrete I_Ocommunication delay.png
Discrete I_Ocommunication delay.png (67.53 KiB) Viewed 2466 times

Should you have any further questions please contact us at [email protected] or call at 1-800-GO VEXTA.
Attachments
Communication delay.JPG
Communication delay.JPG (22.23 KiB) Viewed 2466 times

Mr.Thota
Posts: 34
Joined: Tue Oct 02, 2018 9:45 pm
Location: New Jersey

AZ stepper 8 blinkings error

Post by Mr.Thota » Thu Mar 05, 2020 4:27 am

Hi,

We have supplied the combination of AZM46AC-TS7.2+AZD-CD+CC025VZR, out of total 4 systems, in one system we are getting the following alarm and unable to resolve the same.

No. of alarm blinking 8 times
error is showing in HMI is " LOOP ROTATOR #3 DRIVER ERROR"
after turn off & turn on the machine (or) motor & driver, the motor is rotating around 1~2 minutes and stopping by showing above error.
it is repeating the same every turn-off & turn on the system (or) cut off & on of the motor& driver power supply.

We are trying to resolve this issue, but unable to rectify the same.

REquested to please let us know the exact reason and resolving action procedures to proceed further.

this line of the system is very critical, please try to give your best suggestions.

Thanks in advance !!

Mr.Thota
Posts: 34
Joined: Tue Oct 02, 2018 9:45 pm
Location: New Jersey

Re: AZ stepper start command to motion delay

Post by Mr.Thota » Fri Mar 06, 2020 2:04 am

Hi !!
Good Day !!

Look forward to receiving your valued reply.
even we have gone through alarm error codes in the manual, but unable to found the exact problem.
please look into this and do the favorable immediately.

om_tech_support_KR
Posts: 87
Joined: Thu Jan 11, 2018 3:03 pm

Re: AZ stepper start command to motion delay

Post by om_tech_support_KR » Mon Mar 09, 2020 8:20 am

Hello,

Since there are a couple of different alarm types for the 8 blink alarm I recommend using the MEXE02 software to narrow down the alarm code. If a sensor error its recommended to check the cables for any damage or you can try changing the cables from one of the systems that is working to see if they are the issue.

Post Reply